[Resolvido] O que aconteceu com o VLC?

Olá,

Sei que o BL possui o SMPlayer, mas sou fã do VLC não é de hoje, mas pelo terminal, synaptic e discover todos informam Pacotes Hold; Erros de dependências; etc.

Alguma sugestão?

T+

Obrigado pelo alerta, atualize o pacote chromium-debian que vai resolver.

Olá BIGBRUNO,

Fiz certo?

[email protected]:~$ sudo apt upgrade chromium-debian
[sudo] senha para creto:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
chromium-debian is already the newest version (1.0.0-1big3).
Calculando atualização… Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
vlc-data vlc-plugin-base
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 2 não atualizados.
[email protected]:~$

T+

Faltou um apt update no começo.

1 Curtida

É não sei o que estou fazendo errado ao add o repo do opera que fica duplicado opera-stable.list e opera.list

[email protected]:~$ sudo apt update ; sudo apt upgrade chromium-debian
Atingido:1 http://deb.xanmod.org releases InRelease
Atingido:2 http://cloudfront.debian.net/debian-security buster/updates InRelease
Ign:3 http://linux.dropbox.com/ubuntu cosmic InRelease
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:5 https://download.onlyoffice.com/repo/debian squeeze InRelease
Obter:6 http://linux.dropbox.com/ubuntu cosmic Release [6.600 B]
Ign:7 http://biglinux.lua.im/mirror/biglinux/packages focal InRelease
Atingido:8 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu disco InRelease
Atingido:9 http://archive.canonical.com/ubuntu focal InRelease
Atingido:10 http://dl.google.com/linux/chrome/deb stable Release
Atingido:11 https://brave-browser-apt-release.s3.brave.com disco InRelease
Atingido:12 http://biglinux.lua.im/mirror/biglinux/packages focal Release
Atingido:13 https://deb.opera.com/opera-stable stable InRelease
Atingido:14 http://ubuntu.lua.im/ubuntu focal InRelease
Atingido:15 https://shop.softmaker.com/repo/apt wheezy InRelease
Atingido:16 http://ppa.launchpad.net/lutris-team/lutris/ubuntu eoan InRelease
Obter:17 http://ubuntu.lua.im/ubuntu focal-updates InRelease [106 kB]
Obter:18 http://ubuntu.lua.im/ubuntu focal-security InRelease [107 kB]
Baixados 220 kB em 8s (27,9 kB/s)
Lendo listas de pacotes… Pronto
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
chromium-debian is already the newest version (1.0.0-1big4).
Calculando atualização… Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
[email protected]:~$

He he assim? Acho que sim, mas ainda não resolveu

T+

Agora o que da ao tentar instalar o vlc?

Ele já está na versão atual

[email protected]:~$ sudo apt install chromium-debian
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
chromium-debian is already the newest version (1.0.0-1big4).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
[email protected]:~$

T+

E o vlc continua não instalando?

Sim, não instala:

[email protected]:~$ sudo apt install vlc
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
vlc : Depende: vlc-bin (= 3.0.9.2-1) mas não será instalado
Depende: vlc-plugin-video-output (= 3.0.9.2-1) mas 3.0.10-0+deb10u1 está para ser instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
[email protected]:~$

T+

Veja se não tem que remover o vlc-plugin-video-output antes de liberar a instalação.

Caracas isso mesmo?

[email protected]:~$ sudo apt remove vlc-plugin-video-output
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
fonts-cantarell fonts-comic-neue fonts-inconsolata
kio-extras-data libdolphinvcs5 libplacebo7 powerdevil-data
qml-module-org-kde-quickcharts yad
Utilize ‘sudo apt autoremove’ para os remover.
The following additional packages will be installed:
install-info
Os pacotes a seguir serão REMOVIDOS:
big-executable biglinux-multi-kde biglinux-themes
disable-krunner dolphin dolphin-ptbr-fix gwenview
kde-color-folder kde-service-menu-reimage
kdeshowdesktop-old kio-extras konsole konsolerun-better
libkf5khtml5 libkf5notifyconfig5 libokular5core9 okular
okular-extra-backends phonon4qt5 phonon4qt5-backend-vlc
plasma-desktop plasma-widgets-addons plasma-workspace
plasmamenufork plasmashell-fix powerdevil
rootactions-servicemenu sddm-theme-breeze
vlc-plugin-video-output
Os NOVOS pacotes a seguir serão instalados:
install-info
0 pacotes atualizados, 1 pacotes novos instalados, 29 a serem removidos e 0 não atualizados.
É preciso baixar 89,8 kB de arquivos.
Depois desta operação, 105 MB de espaço em disco serão liberados.
Você quer continuar? [S/n]

T+

Vai no synaptic e ve qual a versão que ta instalada e se precisa coloca a versão 3.0.9, por lá não vai pedir para remover tudo.

3.0.10-0+deb10u1

Marca ele, vai em opções, forçar versão e muda a versão.

Se tiver mais pacotes do vlc instalados na versão 3.0.10 tem que forçar voltar ao 3.0.9 ou remover o pacote

1 Curtida

Bem, seguindo os passos do mestre a gente resolve tudo mesmo.

  • Basicamente abrindo o Synaptic e marcando para foçar a versão 3.0.9 de todos os pacotes do vlc

  • Clicar em aplicar, depois instalar o VLC e tudo resolvido

Grato Bruno!

T+

1 Curtida