[DICA] Contornando o bug gerado pela última versão do libdvdnav e libdvdread

Com a transição das mídias físicas (DVDs e CDs) para a reprodução de vídeos e músicas localmente - ou, até mesmo, por meio de streaming…-, muitos têm ripado seus antigos arquivos para o computador. No caso específico dos DVDs, uma forma de armazenar nos HDs/SSDs os filmes neles presentes é transformá-los em um arquivo .iso. E, para rodar esse formato (assim como várias das extensões multimídia), dois pacotes são essenciais no mundo Linux, sendo o primeiro o libdvdnav e o segundo, o libdvdread.

Acontece, contudo, que as últimas versões dos dois pacotes citados (6.0.1-1 e 6.1.0-1, respectivamente) estão com um bug irritante: elas não permitem a reprodução de arquivos .iso; e, no entanto, são justamente essas as versões utilizadas, neste momento, no Ubuntu 20.04, ainda em fase de testes. Tendo esse problema em vista, decidi escrever este tópico apenas com a dica de resolução do problema, o qual não sei ser individual ou coletivo.

Ao menos em meu notebook, busquei realizar o downgrade dos dois arquivos para a versão utilizada no último BigLinux lançado oficialmente (19.04), aquela que eu usava até poucos dias e que não apresentava o mesmo problema. Eles (os arquivos) podem ser encontrados na página de pacotes do Ubuntu, o LaunchPad.net. Nós os baixaremos de lá:

a) https://launchpad.net/ubuntu/+source/libdvdnav

b) https://launchpad.net/ubuntu/+source/libdvdread

  1. Primeiramente, desça até a seção “The Disco Dingo” em cada um dos endereços acima; em seguida, escolha os pacotes corretos para sua máquina. Em meu caso, por exemplo, baixei os .deb libdvdnav4_6.0.0-1_amd64 e o libdvdread4_6.0.1-1_amd64.

  2. Agora, clique com o botão direito do mouse sobre os arquivos e, na guia “Permissões”, marque a opção “Executável”.

  3. Concluída a etapa anterior, selecione, novamente com o botão direito do mouse, as opções “Ações administrativas” e “Abrir terminal aqui”.

  4. Por fim, rode o comando dpkg -i nome_do_arquivo . deb (sem os espaços).

O terminal fará, a partir de agora, o downgrade de ambos os pacotes.


Espero que as dicas o ajude a contornar o problema enquanto ele não é oficialmente sanado. Fica, também, a sugestão para o BigBruno, caso alguém mais enfrente o hipotético bug, de “desatualizar” os dois pacotes na distro. Como somente atualizei por cima o BigLinux 19.04 para o 20.04, não sei em que pé está esse ponto.

Um abraço. :slight_smile:

1 Curtida

Vamos esperar mais uns dias, se vc puder testar novamente ao lançarem a versão final do Ubuntu 20.04, caso o problema persista, eu reempacoto a versão do 19.04 para o 20.04 dando prioridade para ela ser atualizada.

Tudo bem. :+1:

*Só uma correção de um erro de concordância: “Espero que as dicas o ajudem”. Infelizmente, não consegui editar o texto. rs

1 Curtida

Tópico fixado na seção “Software”

T+