Após atualização não entra mais

Fiz a última atualização 20.04 e não entra mais, nem grub! Como faço agora?

Olá @Deco,

Você tem dual boot, multi boot? Ainda não vimos relatos de atualizações quebrando o sistema, conte-nos mais um pouco.

T+

Tenho dual boot sim, mas não com Windows w sim com Ubuntu Studio.
Há mais de uma semana havia mudado a versão do Biglinux para a 20.04 e, três dias atras o sistema recomendou uma atualização.

Autorizei. Depois que acabou a mensagem era que -havia três ou quatro pacotes que não foram feitou e perguntava se eu gostaria de atualizar. cliquei em atualizar tudo.

Reiniciei, conforme recomendação do sistema, e ele não entra nem o menu de boot. Fica na tela preta com um cursor piscando no canto superior esquerdo. e está assim até agora.

estou usando Biglinux no pen drive agora. Se não houver solução terei que reinstalar o Biglinux.

1 Curtida

Olha se tiver a /home separada também acho melhor a re-instalação, não é ruim não.

É só renomear com outro nickname a nova instalação e depois no dolphin abrir a /home antiga e recuperar o que tinha nela (do Big).

No dual boot é sempre melhor instalar o BigLinux por último mesmo com outro Linux

T+

[RESOLVIDO] - Vou reinstalar.

Não está resolvido.

Reinstalei, fiz seis atualizações recomendadas e sempre iniciei. Tudo bem até a sétima atualização (ver figura). Agora não entra nem o grub.

1 Curtida

Olá @Deco,

Está instalando com o kernel generic? Se sim, pode ser que haja alguma incompatibilidade com placa gráfica, ou algo que não sei te dizer, daí, pergunto, porque não tenta instalar com o kernel xanmod, apenas uma sugestão se é que já não fez.

Vamos aguardar o mestre dos magos aparecer por ai :wink:

T+

Estou dentro d’água! Terei que reinstalar, pois, não posso ficar sem rodar nada, mas quando pedir esta atualização não permitirei.

Tenta instalar com o xanmod, manda atualizar e vê se dá isso.

  • Outra coisa você verifica se há drivers proprietários disponíveis para sua máquina.

T+

Ok! Vou fazer, depois posto resultado.

1 Curtida

Acabei de faz uma atualização, foram dois itens, e agora não entra mais. Perdi o boot, grub, novamente.

Fica piscando o “_” na canto superior esquerdo para sempre.

O que fazer? Reinstalar novamente?

Olha se atualizações estão quebrando o seu sistema tem algo diferente nessa sua instalação.

BigLinux tem que ser instalado em BTRFS
Se tem dual boot, como está seu particionamento?
Alterou alguma coisa na sources.list?
Ou seja, instalou algum aplicativo externo que não esteja na Loja de aplicativos do BigLinux?

Espere mais uma vez alguém com mais experiência, porque re-instalar uma vez até sim lhe recomendei, mas isso de toda atualização quebrar, receio que tem algo não normal ai.

Porque se fosse um BUG do sistema aconteceria com mais usuários

T+

Hoje baixei o iso do site, instalei em modo legacy e fiz todas as atualizações, não ocorreram problemas.

Então refiz a instalação utilizando o modo EFI e fiz todas as atualizações, não ocorreram problemas.

Teoricamente o BigLinux funcionaria bem também em ext4 ou xfs, fiz os testes utilizando btrfs.

Então não sei o que pode estar ocorrendo aí, não consigo reproduzir o problema aqui.

1 Curtida

Desde a última dica que me deste instalei o xanmod e com BTRFS. Não insyalei nada que não fosse da loja e não tenho drive proprietário.

Como faço para recuperar o grub via usb live?

1 Curtida

Pois é, esse negócio de recuperar o grub no BigLinux é só cara ai de cima B. Gonçalves.

Mas ainda assim, pergunto: _você já olhou a ordem de boot no BIOS ou UEFI/EFI?

Pode ser que algo tenha alterado apenas lá, mas isso, se caso tenha dual boot, mas não custa olhar…

T+

Vou verificar depois posto resultado.

Verificado. Legalicy. ordem de boot normal. Tudo certo.

Acho que se refazer o grub via usb live resolveria, mas não sei como fazer.

1 Curtida

Olá Deco,

Vou lhe dar duas notícias, uma boa e outra mal:

Vou te mostrar umas coisas e você vai dizendo ao fórum se ai tudo está parecido:

Seu HD está mais ou menos assim como na imagem acima?

Como está sem acesso ao sistema e novamente no caso do grub eu infelizmente não poderia auxiliar por não saber o que te dizer. Peço espere uma nova opinião e mostre ao fórum como está seu HD, pelo modo live é abrir o Gparted tirar um print e postar aqui.

Continuando em pesquisas aqui…

------ Atualizando -----

Os meus achismos de antes e de agora se dão por eu ter o sistema sempre com qualquer atualização que me aparece desde a instalação aqui, agora mesmo isso abaixo:

[email protected]:~$ sudo apt full-upgrade
[sudo] senha para creto:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Calculando atualização… Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
libkf5cddb-data libkf5compactdisc-data
Utilize ‘sudo apt autoremove’ para os remover.
Os pacotes a seguir serão atualizados:
im-config libnss3 libsmbclient libwbclient0 python3-samba samba-common samba-common-bin
samba-dsdb-modules samba-libs smbclient sudo
11 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 11,0 MB de arquivos.
Depois desta operação, 138 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n]

Ou seja nem grub grub-common quebraram anteriormente

Vamos tentar descobrir o que está fazendo isso ai No BigLinux beta 23

T+

Não entendi o ext4!?

1 Curtida

Você escolheu ele o “ext4” na instalação, agora não tenho como mostrar essa parte aqui, pois, não estou no PC de casa, mas como o Creto é meio sábio (kkkk brincadeira), fiz uma dica de instalação do BigLinux em uma VM simulando um HD físico então dá para se basear nela.

E o que posso sugerir, para nova tentativa para que você não passe por esses problemas é seguir esta dica abaixo:

>>> [Guia] Instalando o BigLinux 20.04 LTS em VM como se fosse em um HD físico.

Boa sorte!!!

T+